Offline cursus

Welkom op onze offline cursus Dreamweaver 4.0.

Je zal regelmatig een update kunnen vinden op onze website: http://www.cursusdreamweaver.be.

De offline cursus wordt slechts elke maand aangepast aan de nieuwe website.

We hopen dat je veel plezier beleeft aan deze cursus en dat je vooral iets bijleert.

Indien je vragen hebt kan je altijd mailen naar vhchris@yahoo.com of naar stijnmistiaen@yahoo.com.

De webmasters,

Chris Van Haevere

Stijn Mistiaen

[image: image90.jpg]Macromedia Droamweaver ¢

Online cursus




Inleiding cursus

Wat, waarom, voor wie,...?

Dreamweaver is een programma voor het werken met HTML en het ontwikkelen en beheren van websites in één. Het programma is ontworpen door Macromedia. Macromedia is de softwaregigant die ook o.a. Flash, Director, Fireworks,... maakt. Dreamweaver laat ons toe zeer complexe websites te maken voor grote bedrijven, maar ook Jantje kan er een eenvoudige website mee aanmaken. Ook deze cursus is gemaakt met het programma Dreamweaver.

Voordelen van Dreamweaver

· zeer professioneel 

· niet te moeilijk 

· gemakkelijk te verkrijgen 

· plugin mogelijkheden voor andere Macromedia-toepassingen zoals Flash, Fireworks,... of Microsoft-programma's 

· ... 

Nadelen van Dreamweaver

· duur 

· af en toe kleine HTML-foutjes (die wel zware gevolgen kunnen hebben) 

· je ziet niet altijd de werkelijkheid 

· ... 

Systeemvereisten

	Windows
	Macintosh

	Intel Pentium-processor
	 

	150MHz of vergelijkbaar
	 

	Windows 95, 98, NT, 2000, ME
	OS 8.6 of later

	 
	QuickTime 3.0 of later

	 
	MRJ 2,2 (voor Flash-items)

	64 MB RAM
	32 MB RAM

	30 MB schijfruimte
	30 MB schijfruimte

	monitor 256 kleuren
	monitor 256 kleuren

	resolutie 800 X 600
	resolutie 800 X 600

	Navigator of Explorer 4.0 of later
	Navigator of Explorer 4.0 of later


 

Installatieprocedure

De gemakkelijkste manier om het installatieprogramma te starten, is de CD-ROM in de cd-romspeler te plaatsen. Het installatieprogramma begint vanzelf. Zo niet, dan kunt jehet op de volgende manier zelf starten:

1. Open de Verkenner 

2. Zoek de inhoud van de CD-Rom 

3. Zoek het bestand Dreamweaver 4 Installer.exe 

4. Dubbelklik op het installatiebestand 

5. Volg de instructies en voer het serienummer in. 

Het werkgebied van Dreamweaver 4.0

Het documentvenster

In het documentvenster staat bovenaan een titelbalk, een menubalk en een werkbalk. We bespreken in dit hoofdstuk deze 3 items grondig.

De titelbalk

De titelbalk bevat de titel van de huidige webpagina. Deze titel verschijnt ook in de titelbalk van de webbrowser. Let wel op: deze titel is niet de naam van de opgeslagen pagina.

De werkbalk

De werkbalk staat onder de menubalk. In de menubalk vind je de verschillende mogelijkheden om met Dreamweaver te werken. De werkbalk verschaft je snel toegang tot de belangrijkste opdrachten. Indien die werkbalk niet op uw scherm blijkt te staan, kan je deze tevoorschijn toveren door te kiezen voor View > Toolbar.
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Met de drie eerste knoppen op deze werkbalk kan je gemakkelijk overschakelen tussen:

· [image: image2.jpg]


de codeweergave (waar je de HTML-bron kan bekijken en wijzigen) 

· [image: image3.jpg]


gesplitste weergave (hier zie je zowel de ontwerpweergave als de HTML-bron) 

· [image: image4.jpg]


de ontwerpweergave 

Naast deze drie knoppen vind je een vak waarin je de titel kan invoeren. Zoals eerder al vermeld, komt deze titel dan in de titelbalk van je browser te staan.

Naast dit titelvakje vindt u nog 6 andere knoppen: 

· [image: image5.jpg]U4,



File Management: dient om bestanden naar de server te up- of downloaden 
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Preview / debug in Browser: als je deze knop indrukt kan je de gemaakte webpagina al eens bekijken in een vooropgestelde browser 
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Refresh Design View: hier kan je direct zien welke veranderingen je hebt aangebracht 
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Reference: geeft toegang tot een aantal naslagbestanden met informatie over CSS (zie hoofdstuk CSS), HTML en Javascripts. Hier kan je instellingen voor tags opzoeken en informatie over JavaScript-objecten en CSS-stijlen vinden 
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Code Navigation: enkel actief als je in de codeweergave of de code-inspector bent. Deze knop geeft je snel toegang tot debugopdrachten 

· [image: image10.jpg]


View Options: met deze optie kan je randen, linialen, het raster en andere opties van de ontwerpweergave aanzetten

De statusbalk

Daarnet hebben we het bovenste gedeelte van het scherm besproken. Daaronder krijg je het werkgebied en nog daaronder kan je de statusbalk terugvinden.
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Deze statusbalk bevat de tagselector, de keuzelijst Windows Size, downloadstatistieken en de Mini Launcher. Hieronder vind je de beschrijvingen van deze items:

· Tagselector: biedt toegang tot de HTML-tags die bij de objecten op het scherm behoren. In de figuur hierboven zie je dat we in de BODY aan het werken waren en een Ordered List aan het maken was. De geselecteerde tag wordt daar in het vet weergegeven. 

· Window Size: hiermee kan je de schermresoluties in Dreamweaver instellen.
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· Connection speed: hier kan je zien hoe lang het zal duren vooraleer heel de pagina geladen is. Natuurlijk hangt dit af van de snelheid van je modem. Je stelt dit in door in de menubalk te klikken op Edit > Preferences > Status Bar. (standaard staat deze optie op een 28.8Kbps modem)
Let op de afmetingen in de keuzelijst Window Size:
De afmetingen rechts (tussen haakjes) geven de schermresolutie weer.
De getallen links zijn de geschatte afmetingen van het browservenster.
vb: als het beeldscherm van de bezoeker op 640x480 is ingsteld, is het zichtbare gebied ongeveer 536x196 pixels. 

· Mini-launcher: hier kan je de verschillende panelen laten weergeven. Hieronder vind je daar meer informatie over.

Panelen en inspectors

Om items te bewerken in Dreamweaver moet je dikwijls gebruik maken van panelen of inspectors. Om bv. te zien welke frames je allemaal hebt gebruikt kan je gebruik maken van het paneel frames. Hoe moet je dat paneel openen? Kies voor Window > Frames. Merk ook op dat naast iedere optie de bijhorende sneltoets is meegeleverd. Indien er veel panelen in je werkgebied openstaan, kan je veel bewerkingen doen tegelijkertijd, maar merk daar wel bij op dat je dan weinig van je ontwerpweergave ziet.

Welke panelen hebben we allemaal? Assets, behaviors, Code inspectors, CSS Styles, Frames, History, HTML Styles, Layers, Library, Reference, Templates, Timeline. Al deze panelen komen aan bod in andere hoofdstukken.

Wanneer we op Window in de menubalk klikken zien we bovenaan Objects, Properties en Launcher staan. Dit zijn onze inspectors:

· Objects: indien je hier op klikt krijg je een verticale werkbalk op het scherm te zien. Dit is een zeer handige tool. Hiermee kan je bv. een tabel of een figuur invoegen. Standaard staat dit palet op Common (meest voorkomend), maar indien je op het uitschuifpijltje klikt kan je het palet Forms tevoorschijn toveren en daarmee kan je dan zeer eenvoudig een formulier aanmaken. Telkens we in deze cursus een item daarover aanhalen verwijzen we ook naar dit palet.
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· Properties: hiermee kan je de verschillende eigenschappen van bv. een stukje tekst instellen, denk maar aan de kleur, de opmaak (vet, cursief,...), de uitlijning (links, rechts, gecentreerd), de hyperlink, de grootte,...
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· Launcher: deze bevat net dezelfde opdrachten als de mini-launcher die in de taakbalk staat.
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Preferences

In Dreamweaver kan je als gebruiker een aantal voorkeuren instellen i.v.m. items zoals kleur en de layers. Je kan deze zeer gemakkelijk instellen door in de menubalk te kiezen voor Edit > Preferences. Je verkrijgt dan volgend scherm:
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In het linkerschermgedeelte kan je de categorie kiezen en rechts verschijnen de mogelijke opties. In dit geval zie je de opties voor de categorie General. Hier kunnen we bv. instellen welke extensie het bestand moet krijgen indien je het opslaat. (.htm)

De help-functie

Indien je na deze cursus toch nog altijd iets wil opzoeken ivm Dreamweaver kan je , net zoals in de meeste andere programma's terecht in de helpfunctie. We bekijken de verschillende mogelijkheden door in de menubalk op Help klikken:
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· Welcome: in dit venster geeft Dreamweaver je een aantal mogelijkheden. Je kan bekijken welke nieuwigheden er bij Dreamweaver 4 bijgekomen zijn t.o.v. de voorgaande versie. Je kan een geanimeerde rondleiding maken. Indien je op Tutorial klikt leer je hoe je een eenvoudige website maakt van begin tot einde. Bij de laatste optie kan je een aantal lessen meevolgen over de meest voorkomende zaken i.v.m. Dreamweaver. 

· Using Dreamweaver: dit is volgens ons de meest bruikbare optie. Hier kan je in de Index alfabetisch naar een bepaald onderwerp zoeken. Indien je op de knop Search klikt kan je zelf een zoekterm intypen.
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Basiscursus HTML

Inleiding

HTML is de taal waarmee je documenten maakt die op het Internet (World Wide Web) kunnen bekeken worden.
HTML is de afkorting van HyperText Markup Language. M.a.w. de taal waarmee je hypertext (dit is de informatie die over het internet wordt verstuurd) kan maken.
Een HTML document bestaat uit verschillende codes, die door een browser (zoals Internet Explorer en Netscape) geïnterpreteerd worden, en die zo vertellen hoe de inhoud van de pagina weergegeven moet worden.
De HTML code bestaat uit elementen en attributen.

Opbouw van HTML

Elementen

Elementen in HTML bestaan meestal uit 3 delen.
- het eerste deel is de activering van het element. Het element staat altijd tussen TAGS <>. vb. <p>
- het tweede deel is de inhoud van het element. Meestal gewone tekst.
- het derde deel is de opheffing van het element. vb. </p>

vb: <p>Dit is een eerst paragraaf. </p>

(Het element p zorgt ervoor dat de browser een nieuwe paragraaf neemt.)

Attributen

Attributen zijn specificaties die horen bij een element. Deze attributen worden opgenomen NA het element maar voor het >-teken. Indien er meerdere attributen zijn, worden deze gescheiden door een spatie.

vb: <p align="center">Een gecentreerde paragraaf.</p>

Het attribuut "align" zorgt er dus voor hoe de paragraaf wordt uitgelijnd

Opbouw van een HTML-document

Een HTML document heeft meestal de volgende structuur (bij frames is dit anders):

<html>
<head>
<title>
...
</title>
</head>
<body>
...
...
</body>
</html>

Dit document bevat 2 grote delen. Een head-gedeelte en een body-gedeelte. In het eerste deel komt er allemaal informatie i.v.m. de website, zoals de titel. In het body-gedeelte komt al de informatie die je wil laten zien in je webpagina. Dit kan tekst zijn, hyperlinks, tabellen, lijnen, figuren,...

Hoe maak je zo een HTML-pagina?

Een html-pagina kan je in verschillende editors maken. De eenvoudigste is Kladblok of Notepad. Natuurlijk zijn er ook grafische programma's om websites te maken zoals Dreamweaver en Frontpage. In Dreamweaver kun je de HTML-bron bekijken of wijzigen door <F10> in te drukken of in de werkbalk op de knop Show Code View te klikken.
Wanneer we een HTML-pagina willen bekijken in onze browser moeten we deze natuurlijk eerst opslaan. De extensie van deze pagina's is altijd .htm of .html.
Indien je de HTML-bron wil opvragen van deze webpagina klik je in je browser op Beeld en dan Bron.

Enkele eenvoudige elementen en attributen
Om dit duidelijk te maken gaan we werken aan de hand van enkele voorbeelden.

De achtergrondkleur instellen


Je kan de achtergrondkleur veranderen door het attribuut bgcolor toe te voegen aan het element body. In het volgend voorbeeld wordt de achtergrondkleur ingesteld op groen.

<body bgcolor="green">
</body>
De achtergrondtekening

Het is ook mogelijk om een achtergrondfiguur toe te voegen. Deze figuur - in GIF of JPG formaat - wordt door de browser zoveel maal naast elkaar gelegd totdat je scherm helemaal gevuld is.

<body background="visjes.gif">
</body>
De tekstkleur aanpassen

Met het attribuut text kan je de tekstkleur aanpassen. In het volgende voorbeeld zal een witte tekst op een zwarte achtergrond getoond worden:

<html>
<head>
<title>HTML voorbeeld</title>
</head>
<body bgcolor="black" text="white">
<p>Deze tekst verschijnt in het wit op een zwarte achtergrond</p>
</body>
</html>
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Headers

Door het element Hn (n wordt vervangen door een nummer van 1 - 6) kan je een titel gaan definiëren.
Na iedere header zal de browser automtisch een lege lijn laten.

<body>
<h1>Dit is de eerste titel</h1>
<h4>Dit is de tweede titel</h4>
</body>
Paragrafen

Zoals eerder vermeld geeft het element P aan dat de tekst in een nieuwe paragraaf moet staan.
Een veel gebruikt attribuut bij P is align. Hiermee kan je de tekst links, rechts of gecentreerd uitlijnen.

<p align="right">Deze tekst wordt rechts uitgelijnd</p>
Lijnen

Op een webpagina wordt er dikwijls een horizontale lijn getrokken. Dit kan een figuur zijn, maar ook zuiver in HTML is dit mogelijk. Hiervoor gebruiken we het element <hr>. Dit element bevat een aantal attributen zoals align, width, size, noshade (geen 3D-opmaak). We verduidelijken dit met een voorbeeld en de oplossing:

<html>
<head>
<title>Voorbeeld lijnen</title>
</head>
<body>
<hr>
<hr size="5">
<hr size="15" noshade>
<hr width ="25%" align ="right" size="10" color="green">
</body>
</html>
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Tekstweergave

In HTML is het zeer eenvoudig om tekst op te maken.
Hier zijn enkele elementen die daarvoor nodig zijn:
<b>Vette tekst</b>
<u>Onderlijnde tekst</u>
<i>Tekst cursief</i>
<sup>Superscript</sup>
<sub>Subscript</sub>
<s>Doorgehaalde tekst</s>
Lettertype en lettergrootte

Je kan een lettertype, lettergrootte en letterkleur kiezen om een titel, een bepaald woord, een paragraaf,... beter te beklemtonen. We gebruiken hiervoor het element FONT. Dit element heeft de volgende attributen: FACE (lettertype), SIZE (lettergrootte) en COLOR (je raadt het al, de letterkleur).

<font face="comic sans ms, courier new" size ="4" color="red">
Deze tekst verschijnt in lettertype Comic Sans ms, grootte 4 en in het rood</font>

Merk op dat we 2 lettertypes hebben opgegeven, nl. comic sans ms en courier new. Wanneer er bij de surfer geen comic sans ms geïnstalleerd is wordt er courier new getoont.

Een nieuwe lijn

We gebruiken hier het element <br>.
Hyperlinks

Als we surfen op internet komen we in 99,9% van de gevallen op een pagina die hyperlinks bevat. Met een hyperlink kan je namelijk heel gemakkelijk surfen van de ene pagina naar de andere door er simpelweg op te klikken.
We maken een hyperlink aan door gebruik te maken van het element A (Anchor) en daaraan voegen we het attribuut href toe.
Een voorbeeld:

<html>
<head>
<title>Hyperlinks</title>
</head>
<body bgcolor="yellow" text="red">
<p>Voor meer informatie bezoek de
<a href="http://www.cursusdreamweaver.be">dreamweaver</a> website!</p>
</body>
</html>
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Een e-mail zenden

Dit systeem werkt net hetzelfde als de hyperlinks. We maken hier echter gebruik van het attribuut mailto

<p>Stuur een mailtje naar
<a href="mailto:vhchris@yahoo.com">Chris</a></p>
Afbeeldingen en tekening

Een afbeelding voeg je toe met het element IMG. Ook hier kan je natuurlijk gebruik maken van enkele attributen. (src, alt, width, height,...)

SRC: bepaalt welke tekening moet geladen worden.
ALT: als je in je browser met de muis over de figuur zweeft verschijnt de omschrijving van de figuur.

Voorbeeld:

<img src="wijnglas.gif" alt="wijnglas" height="200">
Lijsten

In een HTML document kan je gebruik maken van lijsten. Deze lijsten worden voorzien van een opsommingsteken. We onderscheiden een ongeordende lijst van een geordende lijst.

Ongeordende lijst

Met behulp van het UL element kan je een ongeordende lijst aanmaken. Het element kan het attribuut TYPE bevatten. Dit attribuut definieert het symbool voor het opsommingsteken. De mogelijkheden zijn: square, circle of disc. Ieder element uit de lijst begint met het LI element.

Voorbeeld:

<html>
<head>
<title>Voorbeeld ongeordende lijst</title>
</head>
<body>
<ul type="disc">
<li>Eerste item</li>
<li>Tweede item</li>
</ul>
</body>
</html>
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Geordende lijst

Met het OL element maak je een geordende lijst. Het type attribuut bepaalt of het hier gaar over cijfers, romeinse cijfers of letters. Het attribuut start geeft aan wat de startwaarde van de lijst moet zijn.

Voorbeeld:

<html>
<head>
<title>Geordende lijsten</title>
</head>
<body>
<ol type="a">
<li>Eerste item</li>
<li>Tweede item</li>
<ol type="1" start="8">
<li>Eerste item in sublijst</li>
<li>Tweede item in sublijst</li>
</ol>
<li>Derde item</li>
</ol>
</body>
</html>
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Tabellen

Een tabel definieer je met het TABLE element, een rij van die tabel met het element TR en een kolom met TD en een titel met TH.

Voorbeeld:

<html>
<head>
<title>Tabellen</title>
</head>
<body>
<h3>Tabellen</h3>
<table border="1">
<tr><th>Naam</th><th>Nederlands</th><th>Informatica</th></tr>
<tr><td>Chris</td><td>8</td><td>9</td></tr>
<tr><td>Stijn</td><td>7</td><td>10</td></tr>
</table>
<br>
<p>Dit was een tabel</p>
</body>
</html>
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Beginnen met Dreamweaver 4.0

Een eerste site aanmaken

Als je een professionele website maakt moet je daar eerst grondig over nadenken. Welke figuren ga je gebruiken, wat is je hoofdpagina, waar komt jemenu te staan, enz... Al deze gegevens (dus die figuren en bestanden) moeten in één map te komen staan. Wanneer dit gebeurd is kan je aan de slag in Dreamweaver.

Hoe moeten je deze gegevens dan allemaal laden in Dreamweaver?

Hiervoor gaan je gebruik maken van de Site Manager van Dreamweaver.
Je volgt de verschillende stappen:


Stap 1: Je klikt in de menubalk op Site - New Site.
Stap 2: In het volgende venster geef je de gegevens van je website in. Je geeft de website een naam (Site Name) en localiseert (Local Root Folder) hem op je harde schijf.
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Als je alle gegevens over je website ingevuld hebt klik je op OK en dan verkrijg je het volgende scherm:
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Dit is de site manager van Dreamweaver. Hierin staan alle bestanden die je gebruikt. Bovenaan in de titelbalk zie je je de titel van de website. In het linkergedeelte is de sitestructuur grafisch voorgesteld. In het rechtergedeelte staan al de bestanden die nodig zijn voor de opbouw van onze website. Indien je een bestand wil toevoegen aan die lijst klik je rechts ergens in het rechtergedeelte en je kiest New File.
Als je zo een bestand wil bewerken vb. begin.htm dubbelklik je op dat bestand en je komt dan automatisch in de ontwerpweergave van Dreamweaver.

Een bestand bewerken in de ontwerpweergave

Nu kan je eindelijk beginnen aan je website. We bekijken nu enkele basismogelijkheden van Dreamweaver om een site aantrekkelijk te maken.

De eigenschappen van een pagina

De eigenschappen van een webpagina roep je op door in de menubalk te klikken op Modify en dan Page Properties. Je komt dan in het volgende scherm terecht:
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In dit venster kan je de eigenschappen van een pagina bekijken en/of wijzigen.
We bestuderen de verschillende delen:

· Title: hier komt de titel van de webpagina (is niet de naam van het bestand) 

· Background image: zoals we al vermeldt hebben in het hoofdstuk van HTML kan je op de achtergrond van een pagina een figuur plaatsen. Als je op Browse... klikt kan je die figuur selecteren. 

· Background: de achtergrondkleur van je pagina stel je hier in 

· Text: de tekstkleur instellen 

· Links: wanneer je op een webpagina links naar een andere pagina ziet staan hebben die in 95% van de gevallen een andere kleur. Bij deze optie kan je die kleur instellen. 

· Visited Links: wanneer je op een pagina bent die links bevatten naar andere pagina's waar je reeds geweest bent wordt dit meestal aangegeven met een andere kleur dan een gewone link. Hier kan je die kleur instellen. 

· Active links: wanneer je op de link klikt verandert die in een andere kleur. Hier stel je die optie in. 

· Left Margin: hier stel je de linkermarge in (in pixels) 

· Top Margin: de bovenmarge instellen in pixels 

· Margin Width: stelt de linkermarge in (enkel te gebruiken bij Netscape) 

· Margin Height: stelt de bovenmarge in (enkel te gerbuiken bij Netscape) 

· Document encoding: verschillende landen kunnen een verschillend alfabet hebben. Dreamweaver 4 voorziet en hier kun je jouw 'alfabet' selecteren. Voor Europese gebruikers is dit standaard Western (Latin 1). 

Weetje: Document encoding wordt in HTML in de <META>-tag geplaatst. Je verkrijgt dan het volgende:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
Tracing image en Image Transparency: een tracing image is een figuur die je gebruikt als referentie voor je pagina (Dreamweaver plaatst de figuur in je ontwerpweergave maar in je browser merk je er niks van). Image tranparency bepaalt de graad van transparantie van die figuur.

Een figuur invoegen

Een webpagina die enkel uit tekst zou bestaan, zou maar saai zijn. We merken op bijna 99% van alle websites dat er een figuur op staat. 

Stap 1: ga naar de positie waar je je figuur wil invoegen.
Stap 2: klik in de menubalk op Insert en kies Image. Je verkrijgt volgend scherm:
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Stap 3: selecteer de juiste figuur en klik op Select.

Eenvoudige tekstopmaak

Net zoals deze website kan je gebruik maken van verschillende tekstkleuren. Wanneer je een andere kleur voor een bepaald stuk tekst wil gaan gebruiken volg je de volgende stappen:

Stap 1: selecteer de tekst die je wil gaan opmaken.
Stap 2: zorg dat de properties inspector zichtbaar is en open het kleurenpalet.
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Stap 3: selecteer de gewenste kleur of vul een RGB-kleur in.

Om een ander lettertype te selecteren ga net hetzelfde te werk. Je selecteert ook de tekst die je wil opmaken en je kiest in de properties het gewenste lettertype.

Hyperlinks plaatsen

· De verschillende linktypes: 
· Internal Links: dit zijn links binnen één document. Als je bevoorbeeld op het einde van je document staat kan je een interne link naar de bovenkant van het document plaatsen. 

· Local Links: dit zijn links naar documenten op de locale server. (vb. /sales/report.htm) 

· External Links: dit zijn links naar pagina's op een andere web server. (vb. http://www.arteveldehs.be)

· Een 'Internal Link' maken
Interne links, ook wel Bookmarks genoemd, zijn heel makkelijk aan te maken:

Stap 1: je plaatst de cursor op de plaats waar je de link naar toe wil plaatsen.
Stap 2: Kies Insert, Invisible Tags, Named Anchor. Geef het Anchor een naam en kies OK. Merk op dat er op de plaats waar je het Anchor geplaatst hebt het 'Anchor'-symbool komt te staan. Dit is natuurlijk niet zichtbaar in je browser.
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Stap 3: selecteer de tekst of figuur waar je de link wil plaatsen. Open de eigenschappen en schrijf in het vakje naast link de naam van je Anchor voorafgegaan door het #-teken. bv. #top. Test voor alle zekerheid je resultaat in je browser. Sla hiervoor je document op en druk op <F12>.

· Een 'Local Link' maken

Stap 1: Selecteer de tekst of figuur waar je de link wil plaatsen
Stap 2: Open de properties en klik op het 'Browse Icon': 
Stap 3: Selecteer in het volgende scherm het document dat moet geopend worden als je op de link klikt en klik op OK.
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Je zal merken dat de tekst waarop jouw hyperlink is geplaatst verandert is van kleur naargelang je instellingen. Dit hebben we hierboven al omschreven.

· Een 'External Link' maken

Stap 1: Selecteer de tekst of figuur waar je de hyperlink wil plaatsen. Open de properties.
Stap 2: In het vakje naast link typ je de url. bv. http://www.arteveldehs.be)

· Targets

Wanneer je op een link in een website klikt kan deze geopend worden in een nieuw scherm, en hetzelfde scherm of zelfs in hetzelfde frame. Er is dan gebruik gemaakt van de target. Wanneer je de optie Blank kiest opent Dreamweaver de link in een nieuw venster terwijl de optie top de pagina in hetzelfde venster opent. 

CSS

Wat is CSS?

 

· De afkorting voor Cascading Style Sheets 

· Dient voor de opmaak van webpagina's in te stellen 

· Het biedt meer opmaakmogelijkheden dan HTML 

Het komt hier op neer: wanneer je een website maakt wil je al je pagina's dezelfde opmaak meegeven. Dit lukt natuurlijk wel door elke pagina afzonderlijk op te maken maar daar kruipt snel heel wat tijd in. Met CSS maak je één soort 'opmaakprofiel', je past dit toe op al je pagina's en klaar is kees.

Soorten Style Sheets

 

· Inline 

· Embedded 

· Extern 

Inline stylesheet: de stijlcode wordt op de plaats van de actie aan de HTML-tag toegevoegd.
Embedded stylesheet: in elke webpagina wordt in het <HEAD> - gedeelte de volledige CSS-code opgenomen. Die opmaak geldt telkens voor de hele pagina.
Extern stylesheet (meest gebruikte): In elke webpagina wordt in het <HEAD>-gedeelte een link gelegd naar een CSS-bestand dat de opmaak van alle gelinkte pagina's bevat. (het handigste)

Wanneer je een externe stylesheet gebruikt komt de volgende code in je HEAD-gedeelte te staan:

<link rel="stylesheet" href="mystyle.css" type="text/css">

Syntaxis

Een stylesheet bevat een aantal style rules (stijlregels).

Elke style rule bepaalt de opmaak van een bepaald deel uit de webpagina. Een voorbeeld van zo'n style rule: 

P {color: red} 

Een stijlregel is als volgt opgebouwd:

· Selector: dit is het HTML-element waarvoor je een bepaalde opmaak wil bepalen. Zo kan je voor iedere paragraaf een opmaak maken en bijgevolg gebruik je dan het element P. 

· Declaration: de declaration is de definitie van de opmaak die je aan de selector wil toekennen. De declaration staat tussen accolades ({ }). 

· Property en value: elke declaration kent aan één of meer eigenschappen een bepaalde waarde toe. In het voorbeeld hierboven wordt aan de eigenschap color (bepaalt de tekstkleur) de waarde red toegekend. Normaal zal dus alle tekst in de alinea's in het rood weergegeven worden. 

In het voorbeeld hierboven zal dus al de tekst die tussen <p> en </p> staat in het rood gekleurd worden. De tekst die bevoorbeeld tussen <h1> en </h1> staat blijft in de normale opmaak staan.

Natuurlijk stel je meestal niet één eigenschap in maar meerdere. Stel dat je in titel H1 de tekst in het rood wenst en een groene achtergrondkleur wil, dan moet je gebruik maken van 2 declarations nl. color en background-color. Deze twee scheidt je door een komma en dan ziet dit er zo uit:

H1 {color: red; background-color: #33F933}

Om nog een voorbeeld te geven: hier volgt de CSS-code van een website:

body { font-family: Arial, Helvetica, sans-serif; background-color: #003366; color: #CC6600} a:link { font-family: Arial, Helvetica, sans-serif; color: #999999; text-decoration: none} a:visited { font-family: Arial, Helvetica, sans-serif; color: #999999; text-decoration: none } a:hover { font-family: Arial, Helvetica, sans-serif; color: #999999; text-decoration: underline} a:active { font-family: Arial, Helvetica, sans-serif; color: #999999; text-decoration: none } h1 { font-family: Arial, Helvetica, sans-serif; font-size: 14px; font-style: normal; color: #003366; background-color: #CC6600; text-align: center}
In de code hierboven merken we nog een buitenbeentje namelijk de A-tag. Deze tag hebben we al bestudeert in onze cursus HTML. Ze regelt de hyperlinks. De A-tag heeft vier verschillende verschijningsvormen:
standaard, bezocht, actief en gehovered.

We kunnen dus in CSS bv. de kleur opgeven voor een bezochte of een actieve hyperlink. Hier is de code:

A:link {color: red; text-decoration: none} A:visited {color: red; text-decoration: none} A:active {color: blue; text-decoration: none} A:hover {color: green; text-decoration: none}
In het voorbeeld hierboven wordt een hyperlink nooit onderstreept weergegeven. Daar zorgt de 'text-decoration: none' voor. Alle hyperlinks worden rood weergegeven. De actieve hyperlink kleurt blauw. Beweeg je met de muis over een hyperlink, dan verandert de kleur in groen zolang je met de muis over de hyperlink beweegt. 

Nu even genoeg theorie: over naar de praktijk...

Een CSS-style maken in Dreamweaver 4.0

Wanneer we de theorie hierboven hebben doorgenomen kan het zijn dat je er niet teveel van begrijpt en dat het allemaal een beetje wazig overkomt die CSS, maar wanneer je de volgende stappen volgt zal alles verduidelijken. We maken nu een stylesheet aan in Dreamweaver:

Stap 1: Selecteer Text, CSS Styles, New Style.
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We komen in het volgende scherm terecht:
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Stap 2: Nu moet je goed weten wat je wil bereiken. Om het voorbeeld gemakkelijk te houden wil ik dat iedere pagina van onze website een lichtgele achtergrond kleur heeft. Natuurlijk kan je dit instellen in iedere pagina apart, maar nu gebruik je een stylesheet, wat heel wat tijd bespaart. Je selecteert het bolletje Redefine HTML tag (herdefineer de HTML-tag). Bovenaan in het venster merk je dat er iets verandert is. Je kan nu de tag opgeven die je wil gaan veranderen. Zoals je weet wordt de achtergrondkleur in je BODY-tag ingesteld, dus we kiezen hier voor BODY en klikken op OK.

Stap 3: Dreamweaver vraagt nu om je CSS-style op te slaan. Dit bestand krijgt altijd de extensie .css. Je kan hier bv. de naam styles.css opgeven. Zorg er wel voor dat je het bestand opslaat in de map van je site.
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Stap 4: Wanneer je voor Save hebt gekozen kom je in het volgende scherm terecht:
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Omdat je je achtergrond wil veranderen kies je uiteraard voor Background. Bekijk ook zeker eens de andere mogelijkheden. In het rechtergedeelte open je het palet bij Background Color en kies je je lichtgele kleur uit. Klik nu op OK.

Een bestaande style koppelen aan een document.

Nu je een CSS-style aangemaakt hebt wil je die toepassen op al je andere pagina's. Open het document waar je je style wil aan koppelen. Kies Text, CSS-styles, Attach Style Sheet...

Selecteer nu je css-bestand en klik op Select.

Een CSS-style bewerken.

Wanneer je een groot aantal tags gaat herdefiniëren en het resultaat bekijkt kan de gewenste opmaak toch niet naar je zin zijn en wil je je style gaan bewerken. Kies voor Text, CSS-styles, Edit Style Sheet... Je komt in het volgende scherm.
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Selecteer je stylesheet en klik op Edit...
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In het scherm hierboven zie je al je tags die je bewerkt hebt. Selecteer je tag die je opnieuw wil bewerken en klik op Edit... Je komt terug in het scherm van Stap 4 terecht. Wanneer je je veranderingen hebt aangebracht kies je voor OK, Save en Done...
De CSS-selector

Wanneer je een stylesheets gebruikt voor hyperlinks moet je gebruik maken van de CSS Selector. We nemen voor de duidelijkheid een nieuwe pagina en we maken een nieuwe stylesheet. In plaats van te kiezen voor Redefine HTML Tag kies je voor Use CSS Selector. 
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Je merkt op dat je in de keuzelijst naast Selector 4 mogelijkheden hebt:

· a:active 

· a:hover 

· a:link 

· a:visited 
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Kies de gewenste optie klik op OK en de overige vensters zijn net hetzelfde als bij een 'gewone' style.

Tabellen

Inleiding

In dit hoofdstuk leren we hoe je een tabel aan je website kan toevoegen. Een tabel bestaat altijd uit rijen en kolommen. bv. 3 rijen en 2 kolommen zoals het voorbeeld hieronder. Net zoals in Excel spreken we hier over cellen.

	 
	Cel

	 
	 

	 
	 


Een tabel maken

Om een tabel in Dreamweaver te maken volg je de volgende stappen:

1. Plaats je cursor waar je de tabel wil invoegen. 

2. Klik in de menubalk op Insert en kies de optie Table. Je verkrijgt het volgende scherm. 
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Rows: hier geef je het aantal rijen op die je tabel moet bevatten
Columns: hier komt het aantal kolommen van je tabel
Width: je kan hier de breedte van de tabel ingeven in pixels of in een percentage. De breedte komt overeen met het WIDTH-attribuut van het element TABLE.
Border: zoals je merkt in het voorbeeld hierboven heeft elke cel een rand. De dikte van deze rand kan je hier opgeven. Indien je helemaal geen rand wil, spreekt het voor zich dat je hier de waarde 0 ingeeft.
Cell Padding: cell padding is de ruimte tussen de celrand en de celinhoud. 
Cell Spacing: hier kan je de ruimte tussen elke cel veranderen vb.

	 
	 

	 
	 

	 
	 


Selecteren van tabellen, rijen, kolommen en cellen

Selecteren van een tabel

Wanneer je eigenschappen van een tabel wil aanpassen moet je de tabel eerst selecteren. De volledige tabel selecteren is niet altijd gemakkelijk ondervinden wij. Ga rustig met de muis dicht tegen de boven- of onderkant van de tabel zodat de muisaanwijzer zoals in dit voorbeeld verandert:
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Wanneer je op dat moment met de linkermuistoets klikt selecteer je de hele tabel.

Selecteren van een rij of een kolom

Om een rij of een kolom te selecteren plaats je de muis op de boven- of linkerkant van de tabel, zodat de muisaanwijzer in een dikke pijl verandert zoals in het voorbeeld:
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Selecteren van een cel

Om een cel te selecteren klik je simpelweg in die cel, net zoals je tekst zou willen invoeren.

 

Tabeleigenschappen

Je kan alle eigenschappen van je tabel instellen of aanpassen door de Properties Inspector te openen en daarna de tabel te selecteren. Wanneer we dit doen verandert de Inspector zoals in de volgende figuur:
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We bespreken de eigenschappen:

Table name: je kan een tabel een naam geven. Dit is enkel nuttig, maar wel noodzakelijk als je Behaviors gaat gebruiken. Behaviors worden namelijk opgebouwd door Javascripts. En om iets te doen met uw tabel in Javascript heb je de naam van uw tabel nodig. Behaviors worden nog besproken in een ander hoofdstuk.
Rows and Cols: hier geef je het aantal rijen en kolommen in
W - Table Width: je kan hier de breedte van de tabel ingeven in pixels of in een percentage. De breedte komt overeen met het WIDTH-attribuut van het element TABLE.
H - Table Height: je kan hier de hoogte van de tabel in pixels of in een percentage instellen
CellPad: staat voor cellpadding wat we hierboven al besproken hebben
CellSpace: staat voor cellspacing wat we ook al daarnet besproken hebben
Align: de tabel links, rechts of gecentreerd uitlijnen
Border: je stelt hier de dikte van de celrand in

De overige opties zoals Bg Color en Brdr Color spreken voor zich. In die properties inspector staan ook nog enkele icoontjes. Hiermee kan je cellen splitsen en samenvoegen.

Data importeren

Je kan tabellen uit een tekstdocument importeren in Dreamweaver maar dit item staat volgens ons zeker en vast nog niet op punt in Dreamweaver. Zo kan je een eenvoudige tabel uit Excel niet onmiddellijk exporteren naar Dreamweaver. Je moet ervoor zorgen dat het bestand de extensie .txt heeft. Ook uit je kladblok kan je een tabel exporteren. Volg de stappen:

Stap 1: Maak je tabel in kladblok en begruik de tabtoets om de gegevens te scheiden.
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Stap 2: Kies in Dreamweaver voor Insert, Tabular Data.
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Je klikt op Browse en selecteert het tekstbestand. In de uitschuifkeuzelijst naast Delimiter kan je selecteren hoe je de gegevens hebt gescheiden. In ons geval was dat met de tabtoets. Wanneer je het resultaat bekijkt is dit toch nog niet alles en kan je nu in Dreamweaver de tabel aanpassen.

Lay-outweergave

Het ontwerpen van tabellen voor de vormgeving van pagina's is altijd een ingewikkelde zaak geweest. Om veranderingen aan te brengen of het precieze aantal cellen te bepalen, moest de webmaster rijen en kolommen splitsen of samenvoegen en rijen of kolommen oprekken totdat hij of zij tevreden was over het eindresultaat. Dreamweaver 4.0 bevat een lay-out-weergave, waarin u snel en gemakkelijk cellen kunt toevoegen, verplaatsen en bewerken.

Om naar de lay-outweergave te gaan, klik je op de knop Layout View van het paneel Object. Als je overschakelt naar de lay-outweergave, worden de twee lay-outknoppen van het paneel Object actief. Met de ene knop tekent u een lay-outtabel en met de andere een afzonderlijke lay-outcel.
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Een lay-outtabel en lay-outcellen toevoegen

In de lay-outweergave kan je je ontwerp met tabelcellen direct in het documentvenster tekenen. Maak gebieden voor inhoud, menu's en andere elementen van een webpagina door de opdracht Draw Layout Cell te kiezen en cellen voor ieder paginaelement te tekenen.

Je maakt als volgt een paginaontwerp:

· Klik op de knop Layout Mode van het paneel Objects. (Je krijgt eerst nog een helpscherm, klik daar op OK als je alles hebt gelezen) 

· Klik op de knop Draw Layout Cell van het paneel Object. 

· Teken cellen voor de elementen van de pagina. Er wordt automatisch een tabel voor deze cellen gemaakt. 
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· Verplaats cellen door op de rand van de cel te klikken en te slepen. De randkleur verandert van blauw in rood als u in de buurt van het gebied bent waar u kunt klikken. 

· Verander de afmetingen van een cel met de formaatgrepen in het midden van de rand en in de hoeken van de cel 

· Verander de afmetingen van de tabel met de formaatgrepen in het midden van de rand in de hoeken van de tabel. 

Indien je de eigenschappen van een lay-outcel moet je alweer gebruik maken van de Property Inspector.

Inhoud oprekken

Met Autostretch wordt ervoor gezorgd dat kolommen worden opgerekt, zodat ze de hele beschikbare ruimte in het browservenster in beslag nemen. Dit gebeurt ongeacht de grootte van het browservenster. Als je voor een bepaalde cel Autostretch aanzet, wordt de hele kolom van die cel opgerekt. Deze instelling is met name handig voor cellen die het belangrijkste deel van de paginainhoud bevatten. Het menu van de webpagina kan zijn breedte behouden, maar de inhoud kan zich over de hele beschikbare ruimte uitstrekken.

Er worden automatisch opvulafbeeldingen in de tabelcellen opgenomen om er voor te zorgen dat de cellen in alle browsers de beoogde afmetingen hebben. Dit is een oude truc van webontwerpers. Een tranparante GIF van 1 pixel wordt tot een bepaalde breedte opgerekt. Deze afbeelding is in de browser niet zichbaar.

Je zet Autostretch als volgt aan:

· Selecteer een cel door met CTRL ingedrukt op de cel te klikken. 

· Schakel het keuzerondje Autostretch in de Property Inspector in. 
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· Het dialoogvenster Choose Spacer Image verschijnt. (zie figuur hierboven) 

· Create a spacer image file: Er wordt een onzichtbare GIF-afbeelding van 1 pixel gemaakt die in de bovenste cel van iedere kolom komt te staan waardoor de kolom breder wordt. Als je deze optie kiest, wordt je gevraagd of je de afbeelding spacer.gif die daarvoor wordt gemaakt, wilt opslaan. 

· Use an existing spacer image file: als je al een afbeelding voor opvulling hebt gemaakt, kiest u deze optie. Je wordt gevraagd deze afbeelding op te zoeken. 

· Don't use spacer images for autostretch tables: als je deze optie kiest, wordt je gewaarschuwd dat de cellen te klein kunnen worden en niet de breedte behouden die je hebt ingesteld. 

Je kan de opdracht Autostretch ook op een hele kolom toepassen door in de kolomkop het menu te openen. Iedere kolomkop geeft de breedte van de kolom in pixels weer. Je kan ook een opvulafbeelding aan de kolom toevoegen door de opdracht Add Spacer Image te kiezen. Als er een opvulafbeelding in de kolom is opgenomen, wordt de lijn boven de kolom dikker.

Je kan een opvulafbeelding voor een site in het dialoogvenster Preferences opgeven. Je wordt dan niet langer gevraagd om er één te maken of aan te wijzen en de afbeelding wordt zonder meer toegevoegd. Maak of selecteer een opvulafbeelding voor de hele site door naar de categorie Layout View van het dialoogvenster Preferences te gaan. Merk op dat je in deze categorie ook de kleuren van lay-outobjecten in Dreamweaver kunt instellen, evenals het al of niet automatisch invoegen van opvulafbeeldingen.

Frames & framesets

Enkele jaren geleden nog waren vele surfers tegen het gebruik van frames omdat ze frames te verwarrend vonden. Vandaag maken veel websites gebruik van frames. Frames zijn een ideale manier om een website mooi en overzichtelijk te presenteren. 

Een goed voorbeeld is een website met een inhoudsopgave die voortdurend beschikbaar moet zijn. Ook bij deze website is dat ook zo. Op dit moment zal je 3 frames kunnen onderscheiden, namelijk links (waar het menu staat), bovenaan rechts (waar je de hoofdstukken van de cursus kan kiezen) en dit frame (waar de eigenlijke tekst in komt). Hoeveel je dit frame nu ook naar beneden of naar boven scrollt, de frames bovenaan en links zullen niet wijzigen.
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Framesets

Elk frame bestaat uit een afzonderlijke html-pagina, 1 voor ieder frame, die bij elkaar worden gehouden door een html-pagina met alleen de frameset. In deze frameset staat enkel waar welke frame moet staan en hoe groot deze zijn, laten we dus maar zeggen het skelet van de webpagina.

Er kunnen 2 soorten html-pagina's in frames staan, namelijk reeds bestaande html-pagina's en nieuwe html-pagina's. Hoe we dit precies gaan doen komt verder in dit hoofdstuk aan bod.

Frames opslaan

Als je met frames werkt, wordt het iets ingewikkelder om je webpagina op te slaan. Kies voor File -> Save Frame om het frame op te slaan waarin je aan het werken bent. Om een frameset op te slaan kies je voor File -> Save Frameset. Nu zou het kunnen dat in het menu File de optie Save Frameset (As) niet beschikbaar is. Een mogelijke verklaring is dat de cursor in een frame staat. Selecteer daarom eerst de frameset. Dit doe je door met de muiscursor boven de frame border te staan. Deze cursor zal nu in een dubbel pijltje veranderen. Als je nu klikt op de rechtermuisknop is de frameset geselecteerd. Kies nu voor File -> Save Frameset.

Nog een andere manier om (alles) op te slaan is via File -> Save All Frames. TIP: als je de frames en frameset nog geen naam gegeven hebt, is het beter van deze eerst apart op te slaan (via File -> Save Frame), zonder dat je dus gebruik maakt van File -> Save All Frames. Anders is het nogal verwarrend, je weet niet precies welk frame je nu eigenlijk aan het opslaan bent.

Een eerste pagina met frames maken

Er zijn 3 methodes om frames te maken:

· Maak de frame borders zichtbaar (View -> Visual Aids -> Frame Borders) en sleep deze randen om nieuwe frames te maken. 

· Gebruik de opdrachten in het submenu Frameset van het menu Modify. 

· Gebruik de kant-en-klare frame-instellingen van het paneel Object. 

Wij kiezen voor de eerste manier. Open een nieuwe pagina in Dreamweaver. Zorg ervoor dat de frame borders te zien zijn. Nu ga je met je muiscursor op de linkse frameborder staan en je sleept die terwijl je de alt-knop ingedrukt houdt een beetje naar rechts. Nu heb je dus een pagina met 2 frames! We hebben nu dus 3 html-bestanden: het linkse frame, het rechtse frame en de webpagina met de frameset.

TIP: Als je een frame wilt verwijderen sleep je gewoon de frameborder naar de kant. 
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We gaan eens even een kijkje nemen in de code van de webpagina van de frameset.

<html>
<head>
<title>Untitled Document</title>
</head>

<frameset cols="118,892">
<frame src="file:/UntitledFrame-10">
<frame src="file:/Untitled-4">
</frameset>
<noframes><body bgcolor="#FFFFFF" text="#000000">

</body></noframes>
</html>

Wat wil dit nu feitelijk allemaal zeggen?

<frameset cols="118,892">
begin van de frameset, deze bestaat uit 2 kolommen, 1 van 118 pixels breed en 1 van 892 pixels breed

<frame src="file:/UntitledFrame-10">
<frame src="file:/Untitled-4">
src staat voor bron (source), dit is de bron waar de html-pagina's staan die in de frames moeten komen. In dit geval zijn ze untitled omdat we ze nog niet hebben opgeslaan, we hebben ze dus nog geen naam gegeven 

In het linker-frame typt u nu "menu". Als u nu meteen naar de code gaat gaan kijken zal u het onderstaande zien staan:

<html>
<head>
<title>Untitled Document</title>
</head>

<body bgcolor="#FFFFFF" text="#000000">
menu 
</body>
</html>

Je ziet dus niets staan over frames. Wat je wel ziet is de html-code van de webpagina van het linkerframe. We zien dat het woord "menu" hier in de code staat. Ga nu eens naar de html-code van de framesetpagina kijken. Selecteer dus eerst de frameset (ga met de muisaanwijzer boven de frame borders gaan staan en klik op de rechtermuisknop, of via het panel frames: selecteer de buitenste frame border) en bekijk de html-code. U zal opmerken dat deze ongewijzigd blijft, hier vindt u dus nergens het woord "menu". Dit komt dus omdat de framesetpagina enkel de verwijzingen naar de pagina's die in de frames moeten komen bevat, maar niet de inhoud ervan.

Als de bezoeker de URL van de framesetpagina invoert, laadt de browser automatisch de afzonderlijke pagina's van ieder frame.

Frames maken via het menu Modify -> Frameset

Doe-opdracht: we maken een nieuwe frameset en gaan die dan ook opslaan.
Open een nieuwe pagina. Typ hier het woord "boven" in en sla deze pagina op onder de naam boven.htm (File -> Save -> kies de juiste map en vul de naam boven.htm in). Kies nu voor Modify -> Frameset -> Split Frame Up
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Je scherm zal nu in 2 frames gedeeld worden, zoals hieronder getoond:
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Dreamweaver heeft ons scherm nu in 2 gesplitst, en aangezien we voor Split Frame Up hebben gekozen, is de pagina boven.htm in het onderste frame geplaatst. Indien we voor Split Frame Down hadden gekozen, had dreamweaver de pagina boven.htm in het onderste frame geplaatst.

In het onderste frame typ je nu: "dit is het onderste frame". Sla dit op onder de naam onder.htm.
Zorg er nu voor dat het onderste frame kleiner wordt dan het bovenste. Je doet dit door de frame border in het midden van het scherm te selecteren en naar onder te slepen. Hier moet je de alt-knop niet ingedrukt houden. Stel dat je dat wel zou doen, dan zou je gewoon een nieuw frame aanmaken in plaats van de grootte van je frame te wijzigen.

We willen nu ons bovenste frame in een linker en rechtergedeelte splitsen. Plaats dus eerst je cursor in het bovenste frame en kies dan voor Modify -> Frameset -> Split Frame Right. Je zal zien dat het woord "boven" nu in het frame rechtsboven in het scherm staat. Indien je had gekozen voor Modify -> Frameset -> Split Frame Left, dan zou het woord "boven" (en dus de pagina boven.htm) in het linkerboven frame van ons scherm gestaan hebben. Verander het woord "boven" in "rechtsboven" en sla deze frame op als rechtsboven.htm. Als we nu kiezen voor File -> Save gaat deze pagina opgeslaan worden onder de naam boven.htm, en dat is niet de bedoeling. We kiezen dus voor File -> Save As en vullen als naam rechtsboven.htm in. 

In de map waar je deze pagina's hebt opgeslaan mag je nu de pagina boven.htm verwijderen, omdat je dat nu toch niet meer gebruikt (je hebt het vervangen door rechtsboven.htm)

In het linkerframe mag je de zin "dit is het linkerboven frame" intypen. Sla dit frame op onder de naam linksboven.htm. Je slaat ook de frameset op: je selecteert deze frameset, kiest voor File -> Save Frameset en slaat de frameset op onder de naam frameset.htm.

Resultaat: We hebben nu 4 html-pagina's (TIP: html-pagina's mogen opgeslaan worden met de extensies html of htm). Wij kiezen hier voor htm omdat dat het kortst en meest gebruikt is. In een aantal gevallen (die we hier nog niet bespreken) moet je de extensie .html gebruiken, bijvoorbeeld bij het aanmaken van een gastenboek). De 4 pagina's zijn:

· linksboven.htm 

· rechtsboven.htm 

· onder.htm 

· frameset.htm 

Het resultaat zou er zo moeten uitzien:
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Het paneel frames (Window -> Frames)
In het paneel frames kun je afzonderlijke frames selecteren en de eigenschappen van de frames instellen. Merk op dat het paneel een visuele weergave van de frames van de webpagina geeft. Een frame selecteren doe je door erop te klikken op het paneel (of door alt ingedrukt te houden en te klikken in het documentvenster). Het voordeel van het paneel frames is dat je zo een mooi overzicht krijgt en je kan de frames op een eenvoudige manier selecteren.
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De eigenschappen van een frameset

De eigenschappen van een frameset kan je bekijken in de property inspector (zoals hieronder afgebeeld)
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	Frameset Rows: 1 ; Cols: 2
	Hier kan je zien uit hoeveel rijen en kolommen een frameset bestaat. 

	Borders
	Hier kan je dus kiezen of je de borders (de grijze randen) kan zien op je website. Aangezien dit niet echt mooi is gaan we bijna altijd voor No kiezen.

	Borders Width
	De breedte van de randen instellen.

	Border Color
	De kleur van de randen.
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	Onze frameset bevat 2 frames, hier voorgesteld als kolommen, en hier kan je een kolom selecteren.

	Column Value Units
	De breedte van de geselecteerde kolom (die dus de frame voorstelt) instellen. Bij Units kan je kiezen voor Pixels (bij Value vul je dan het aantal pixels in), Percentage (bij Value kies je dan het percentage) en Relative (de breedte is afhankelijk van de breedte van de andere kolom).


De eigenschappen van een frame

De eigenschappen van frames kan je bekijken in de property inspector
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	FrameName
	Hier vul je de naam van het frame in (dit is niet de naam van de html-pagina!). In dit geval is dat "rechtsboven". Je maakt hier best een gewoonte van omdat we dat zullen nodig hebben wanneer we links gaan openen in een bepaald frame, maar meer hierover verder in dit hoofdstuk.

	Src
	De bron (source): de naam van de html-pagina en de plaats waar ze zich bevindt. De beste manier om een reeds-bestaande html-pagina in een frame te laden is op het gele mapje te klikken, en dan een pagina te selecteren.

	Scroll
	Hier kan je kiezen of de gebruiker kan scrollen (door middel van de schuifbalk rechts van een frame) door je frame. Je hebt de keuze uit Default, Yes, No en Auto. Bij Yes staan er zowel rechts als onderaan het frame schuifbalken. Bij No staan er geen schuifbalken. Bij Auto worden er alleen maar schuifbalken gezet als het nodig is. Default geeft hetzelfde resultaat als Auto.
In het frame waar het menu komt gaan we meestal voor Scroll: No kiezen, tenzij het echt een lang menu zou zijn. Het frame met de inhoud geven we meestal Scoll: Default (dit is de standaardinstelling, dus deze moet eigenlijk niet gewijzigd worden).

	No Resize
	Hier kan je kiezen of de surfer de grootte van je frames kan aanpassen. Je vinkt dit best aan.

	Borders
	Hier kan je dus kiezen of je de randen kan zien op je website. Aangezien dit niet echt mooi is gaan we bijna altijd voor No kiezen.

	Border Color
	De kleur van de randen.

	Margin Width en Height
	Hier kan je de breedte en de hoogte van de marge instellen, uitgedrukt in pixels.


Frames nesten

Frames kunnen ofwel meerdere rijen bevatten, ofwel meerdere kolommen, maar niet allebei tegelijk. Daarom gaan we frames nesten. Dit is dus eigenlijk een frameset in een frame plaatsen.
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Wat we hierboven zien zijn 3 frames, maar dit zijn wel degelijk 2 framesets: de eerste frameset bestaat uit 2 rijen. De tweede frameset zit in de bovenste rij (het bovenste frame) en die bevat 2 kolommen.

Een titel instellen

De titel die je in de titelbalk ziet, is de titel van de pagina met de frameset. Om de titel in te stellen, kies je Modify -> Page Properties terwijl de hoofdframeset is geselecteerd. Voer een titel in het vak Title in.

Indien de browser geen frames ondersteunt...

Oude browsers kunnen nog niet met frames werken. Alhoewel de meeste surfers moderne browsers hebben die frames ondersteunen, zijn er toch nog altijd enkele mensen die een oude browser gebruiken. Als die dan onze website wil bekijken, zullen ze gewoon een witte pagina zien staan. We willen dat er eigenlijk op die pagina een tekst komt met de boodschap dat hun browser geen frames ondersteunt. Als je de frameset selecteert, en dan ga je naar Modify -> Frameset -> Edit NoFrames Content. Hier kan je die boodschap nu intypen.

Frameobjecten

	[image: image59.jpg]Lagou.

Vi





	Als je op een snelle manier een pagina met frames wil maken, kies je gewoon voor de vooraf-gedefiniëerde frameobjecten die in het onderdeel Frames van het paneel Objects (als je deze niet ziet ga je naar Window -> Properties) staan.

Je zal merken dat er een frame in het blauw staat en een frame (of meerdere frames) in het wit. Het frame in het blauw duidt aan waar de html-pagina waar je nu mee bezig bent zal staan (in welke frame) ten opzichte van de andere frames.


Een link openen in een bepaald frame
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In dit voorbeeld hebben we nu een webpagina met een frameset die 2 frames bevat. In het linkerframe staat een menu met verschillende links. We willen dat als we op een link klikken, die geopend wordt in het rechter (grootste) frame. We maken dus van gewone tekst (bij ons bv. keuze 1) eerst en vooral een link. Je selecteert het document dat je wil linken (bij Link in de Property Inspector), en je zal zien dat daarnaast rechts het keuzemenu Target wit wordt in plaats van grijs. Klik op het pijltje en je zal daar een aantal mogelijkheden zien verschijnen. Vier daarvan zijn standaard:

· _blank: opent een gekoppelde webpagina in een nieuw browservenster 

· _parent: opent een gekoppelde webpagina in de hoofdframeset. Als de hoofdframeset niet genest is, vult de gekoppelde pagina het hele browservenster 

· _self: opent een gekoppelde pagina in hetzelfde venster of frame waarin de hyperlink staat, dit is de standaardinstelling 

· _top: opent een gekoppelde webpagina in het hele browservenster 

In dit lijstje zullen ook de namen van de frames komen die je hebt aangemaakt. Dit maakt het ons eigenlijk heel gemakkelijk om de gekoppelde webpagina in het juiste frame te laten verschijnen; je klikt gewoon de naam aan van het frame waar je de webpagina wilt laten in verschijnen.

Layers

Lagen of layers zijn containers die je in staat stellen elementen op iedere gewenste plek op het scherm te positioneren.

We kunnen op 2 manieren een layer toevoegen:
- via Insert > Layer
- druk op de knop Draw Layer van het paneel Object, sleep dan met de kruiscursor over de pagina tot de laag ongeveer de gewenste afmetingen heeft.
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Wanneer je een laag selecteert (klik eerst ergens in de layer, daarna op het vierkantje linksboven de layer), zal je opmerken dat deze formaatgrepen (zwarte blokjes op de lijnen) heeft, hiermee kan je dus het formaat van zo'n layer wijzigen. 

In de property inspector kan je de breedte en hoogte van de layers instellen. 

Een layer positioneren

Je kan een layer gewoon slepen naar de plaats waar je de layer wilt hebben. Eén van de grote voordelen van een layer is dat je deze tot op een pixel kan positioneren op je scherm. Stel dat je dus een afbeelding ergens op een bepaalde (precieze) plaats wil hebben, dan plaats je die afbeelding gewoon in een layer. Hoe gaan we dat nu doen? 
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Het aantal pixels bij L (left) duidt aan hoeveel pixels de layer van de linkerkant van de pagina is verwijderd. T (top) duidt aan hoevel pixels de layer van de bovenkant van de pagina is verwijderd. 

De naam van een layer

Links bovenaan van de property inspector zie je staan Layer ID. In het witte vakje daaronder kan je de naam van de layer invullen (in dit geval is dat dromen). Maak er een goede gewoonte van dit altijd te doen, het zal je werk er veel eenvoudiger op maken als je met meerdere layers begint te werken.

Andere eigenschappen van layers:

· W (breedte): hier kan je de breedte in pixels van een layer instellen. 

· H (hoogte): hier kan je de hoogte in pixels van een layer instellen. 

· Z-index: elke layer die je maakt, krijgt automatisch een Z-index. Deze begint bij 1. Stel dat je een pagina hebt met 5 layers hebt die deels op elkaar liggen. De layer met Z-index 5 ligt bovenaan en zal dus volledig te zien zijn. De layer met Z-index 1 ligt altijd onderaan. De Z-index is dus eigenlijk de stapelvolgorde van de layers. 

· Vis: dit is de zichtbaarheid: is een layer zichtbaar of niet. Bij Visible is de layer zichtbaar. Bij hidden zit de layer verstopt, hij is niet zichtbaar (maar hij is er wel!). Default is afhankelijk van de browser, maar zal in de meeste gevallen hetzelfde zijn als Visible.
Inherit: de laag krijgt dezelfde zichtbaarheid als de moederlaag. Dit gebruik je bij het nesten van lagen. 

Overflow

De instellingen voor Overflow bepalen wat er gebeurt als de inhoud van een laag groter is dan de laag zelf. Er zijn 4 instellingen:

· Visible: de laag wordt naar beneden en rechts uitgebreid, zodat alles op de laag zichtbaar is. 

· Hidden: de laag behoudt zijn afmetingen, zodat inhoud die er buiten valt niet zichtbaar is. 

· Scroll: als de inhoud buiten de afmetingen van de layer valt, blijft de grote gelijk, maar er verschijnen schuifbalken. 

· Auto: Er kan worden geschoven met behulp van een schuifbalk als de inhoud groter is dan de laag. 

Clip

Deze coördinaten bepalen de grootte van het zichtbare gebied. Met deze optie kan je een bepaald deel van de inhoud verborgen houden. In de Property Inspector kan je voor Clip 4 waarden instellen, die een kader rond de inhoud van de laag definiëren:

· T (top) voor boven 

· L (left) voor links 

· R (right) voor rechts 

· B (bottom) voor onder 

De waarden die je ingeeft bepalen de afstand tot de rand van de laag, en niet tot de rand van de pagina.
Dit is wel een beetje verwarrend, want zowel de L-waarde als de R-waarde geeft het aantal pixels weer vanaf de linkerkant van de layer. Hetzelfde geldt voor de T-waarden en de B-waarde, die beiden het aantal pixels weergeven vanaf de bovenkant van de layer.

Lagen nesten

Je kan een laag in een andere laag plaatsen, de nieuwe laag wordt dan genest in de moederlaag. De dochterlaag erft de zichtbaar van de moederlaag, en als je de moederlaag verplaatst, zal ook de dochterlaag verplaatsen.

Je doet dit door in de moederlaag te gaan staan met de cursor, en dan kies je voor insert > layer.
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Als je dan gaat kijken in het paneel Layers, zie je dat de geneste layers met een inspringing worden weergegeven.

Tags voor lagen
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Tags doen verschillende dingen in verschillende browsers. De tag <div> (in de html-code) is de meest gebruikte tag. Voor CSS met layers kan je de tags <span> en <div> gebruiken. Je kan toch het best de tag <div> gebruiken.

De tag <layer> werkt wel bij Netscape Navigator (tot versie 6.0), maar niet bij Internet Explorer. 

Behaviors

Dreamweaver-behaviors (gedragingen) worden gebruikt om interactiviteit aan een website toe te voegen. Vroeger moesten hier (soms) ingewikkelde javascripts voor geschreven worden. Bij Dreamweaver zitten enkele van die javascripts ingebouwd, zodat je als gebruiker geen kennis moet hebben van javascript om toch een beetje interactiviteit aan je website toe te voegen.

Wat is een Dreamweaver-behavior?

Een behavior is een actie die wordt geactiveerd door een gebeurtenis. Bijvoorbeeld, als je met de cursor over deze tekst zal komen, zal je zien dat er in de statusbar onderaan een tekstje zal verschijnen. De gebeurtenis in dit voorbeeld is dat je met je cursor over de tekst gaat. De tekst die in de statusbalk verschijnt is de actie.
Dus: gebeurtenis + actie = behavior.

Overzicht van de meest gebruikte gebeurtenissen

	onMouseOver
	De actie wordt geactiveerd wanneer je de muis op het object plaatst.

	onMouseDown
	De actie wordt geactiveerd wanneer je de muisknop indrukt.

	onMouseUp
	De actie wordt geactiveerd wanneer je de muisknop loslaat.

	onClick
	De actie wordt geactiveerd wanneer je met de muisknop klikt (= de muisknop indrukken en terug loslaten).

	onDblClick
	De actie wordt geactiveerd wanneer je dubbelklikt met de muisknop.

	onLoad
	De actie wordt geactiveerd wanneer een object of webpagina geladen is.

	onBlur
	De actie wordt geactiveerd wanneer een object de focus verliest.

	onFocus
	De actie wordt geactiveerd wanneer een object de focus krijgt.


Kort overzicht van enkele acties

	Check Browser
	Kijkt na welke browser de bezoeker gebruikt.

	Check Plugin
	Controlleert of de bezoeker een bepaalde plug-in geïnstalleerd heeft.

	Go To URL
	Opent een bepaalde URL in de browser.

	Open Browser Window
	Opent een nieuw browservenster.

	Play Sound
	Speelt een geluid af.

	Popup Message
	Toont een waarschuwingsvenster met tekst.

	Set Text of Frame
	Plaatst een tekst in een frame.

	Set Text of Layer
	Plaatst een tekst in een layer.

	Set Text of Status bar
	Plaatst een tekst in de statusbalk.

	Show-Hide Layer
	Toont of verbergt een bepaalde layer.

	Swap Image
	Vervangt een afbeelding door een andere afbeelding.

	Swap Image Restore
	Herstelt de vorige vervangen afbeelding.

	Validate Form
	Kijkt de gegevens van een formulier na.


Een eerste behavior maken

Hieronder zie je een tekst met een afbeelding naast. Als je over de link 'Toon route' gaat met de cursor, moet de afbeelding veranderd worden in een andere afbeelding met een plan daarop. (Voor wie wil kan deze 2 afbeeldingen hier downloaden)

	Hiernaast zie je dus een foto van het concertgebouw in Brugge. Ga met je muiscursor over deze tekst om een routebeschrijving te zien.
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Allereerst is het belangrijk dat het juiste object geselecteerd wordt. Dit kan een webpagina zijn, een link, een afbeelding, een layer... In het bovenstaande voorbeeld moet je in Dreamweaver de tekst naast de foto selecteren. Hou er wel rekening dat je als je een gewone tekst selecteert, eigenlijk de hele paragraaf selecteert! Schrijf je dus nog tekst bij in dezelfde paragraaf, dan maakt ook deze tekst uit van het object. Maak je echter een nieuwe paragraaf aan (op enter drukken), dan zal de tekst in die nieuwe paragraaf geen deel meer uitmaken van het object.

Je zorgt ervoor dat het behavior-panel zichtbaar is (Window -> Behaviors). 
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	Om een behavior toe te voegen klik je op de "+". Er verschijnt dan een menu. We willen een afbeelding wisselen dus we kiezen voor Swap Image. Je zal dan in een venster komen waar je de afbeelding kan kiezen die moet verschijnen als de bezoeker met de cursor over het object komt.
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	Bij Actions zie je dus dat er Swap Image verschijnt. Bij Events verschijnt er onMouseOver. Indien je een andere gebeurtenis wil selecteren moet je eerst op onMouseOver klikken en dan zal er daarnaast ook een pijltje verschijnen. Als je daar op klikt zullen er nog verschillende soorten Events verschijnen waar je uit kan kiezen.


Als je dit nu eens gaat testen zal je zien dat dit nog niet helemaal klopt. Eens je met cursor over de tekst gaat, verschijnt de andere afbeelding. Maar als je met de cursor terug van de tekst gaat, blijft die afbeelding staan, terwijl je eigenlijk terug de oorspronkelijke afbeelding zou moeten zien.
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	Je zal dus nog een behavior moeten maken. Klik op de "+", en kies nu voor Swap Image Restore. Deze actie zet de afbeelding terug. Aangezien de oorspronkelijke afbeelding terug moet verschijnen als de muiscursor niet meer over de tekst staat, kies je bij Events voor onMouseOut.


Zo, nu heb je een eerste eenvoudige behavior gemaakt! 

Hieronder vind je de code die Dreamweaver in de html-code plaatst. Deze moest vroeger zelf ingetypt worden!

<script language="JavaScript">
<!--
function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_swapImgRestore() { //v3.0
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}

function MM_findObj(n, d) { //v4.0
var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
if(!x && document.getElementById) x=document.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>

Formulieren 

Je kan formulieren gebruiken om informatie te verzamelen, zoals opmerkingen of bestellingen, en communiceren met bezoekers. In een formulier kan je bijvoorbeeld de gebruiker om zijn naam en e-mailadres vragen, een gastenboek laten tekenen, of informatie geven over de website. 

Een eerste formulier maken

[image: image69.jpg]Modfy Text Commands Ste Window Help

Inage Culvitst [c 0
Ineractive Images , % ©. L
Vedia »
Table CuleaeT
Layer
Frames »
Fom
IM Text Feld
Server-5ide Incude Butten
CheckBox
Enelink Rado Button
= LitfMers
Tede b e Field
el e Inage Feld
Invisble Tags »|  Hden Fied
Head Tags ,
ump Mer
Special Charactrs [

et More Objects.




 

Een eerste mogelijkheid is via Insert > Form (selecteer wel eerst de plek waar je het formulier wil krijgen).

Dan verkrijg je een kader met rode stippellijn op je scherm. Alles wat je daarin zet, zal tot het formulier behoren. Om bijv. een knop toe te voegen kies je voor Insert > Form > Button.
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	Je kan een formulier of formulierobjecten (vb. een knop of tekstvak ook invoegen via de categorie Forms van het paneel Objects.


 

De eigenschappen van een formulier

Je selecteert een formulier door te klikken op de rand van het formulier. In de property inspector kan je dan de eigenschappen van het formulier bekijken.
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Form Name is de naam van het formulier. Het is aangeraden om een formulier altijd een naam te geven.
Action is een URL die wijst naar een toepassing, in de meeste gevallen een script op de server, die de formuliergegevens verwerkt.
Method zegt aan de server hoe de gegevens verwerkt moeten worden.

 

De verschillende objecten die je in een formulier kan plaatsen:
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	een tekstvak (text field)
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	een knop (button)
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	een aankruisvakje (checkbox)
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	een keuzerondje (radio button)
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	een lijst / menu (list / menu)
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	een bestand-veld (file field)
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	een afbeelding (image field)
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	een verstopt veld (hidden field)
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	een keuzemenu (jump menu)


 

Hieronder gaan we eventjes dieper ingaan op enkele van volgende objecten.

De eigenschappen van een tekstveld
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· Char Width: bepaalt de grote van het tekstvak en het aantal tekens dat zichtbaar is. 

· Max Chars: het maximum aantal karakters dat een tekstveld bevat. Dit kan meer / minder zijn dan de breedte van het tekstveld. 

· Type: er zijn 3 soorten tekstvelden, namelijk single line (1 lijntje), multi line (meerdere lijnen), en password (als je dan iets in het tekstveld typt zullen er sterretjes - of bolletjes in Windows XP -verschijnen). 

Als u gekozen hebt voor multi line:
Dan verandert het veld Max Chars in het veld Num Lines (het aantal lijnen waaruit het tekstveld mag bestaan).
Nu kan je in de vervolgkeuzelijst Wrap ook iets selecteren. De tekst in een tekstgebied gaat standaard verder op een nieuwe regel zodra de gebruiker het einde van een regel bereikt. Je kan de tekstomslag echter uitschakelen door de optie Off te kiezen in de vervolgkeuzelijst. Deze lijst bevat nog 2 andere opties: Physical en Virtual. Physical zorgt ervoor dat de tekst aan het einde van het vak wordt omgeslagen door een harde return (het teken CRLF) in te voegen. Virtual zorgt er eveneens voor dat de tekst wordt omgeslagen, maar voegt geen teken in.

Je kan in het tekstvak ook nog een standaardwaarde instellen in het veld Init Val.

De eigenschappen van een knop
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· Button Name: Dit is de naam die je aan de knop geeft. Het is aangeraden om ook hier weer een naam te geven. 

· Label: Dit is de tekst die op de knop komt. 

· Action: Je kan hier kiezen wat de functie is van de knop: ofwel om de gegevens binnen het formulier te verzenden (Submit Form) ofwel om de de gegevens in het formulier te wissen (Reset form). Als je kiest voor None zal de knop geen functie hebben. 

De eigenschappen van een aankruisvakje
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· Typ een naam voor het selectievakje in het naamvak uiterst links in de Property inspector. 

· Checked Value: Hier Typ je een controlewaarde in. Deze waarde wordt verzonden naar het script of de servertoepassing. 

· Initial State: Moet het selectievakje standaard aangevinkt (checked) zijn of niet (unchecked)? 

De eigenschappen van een keuzerondje
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Keuzerondjes zijn in tegenstelling tot aankruisvakjes gegroepeerd, en ze werken afhankelijk van elkaar. Keuzerondjes die tot een zelfde groep behoren geef je een zelfde naam. Ook hier is de Checked Value een controlewaarde die verzonden wordt naar het script of de servertoepassing.

De eigenschappen van een menu
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· Ook hier weer geef je je object (een menu in dit geval) eerst en vooral een naam. 

· Type: Je kan kiezen voor een menu of een lijst. Hier kies je voor Menu. 

· List Values:
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Hier geef je de waarden in die in je menu moeten komen. Om een nieuwe waarde in te geven druk je op "+". Om een waarde te wissen, selecteer je eerst deze waarde die je wil wissen, en druk je dan op "-". Om een waarde hoger of lager te positioneren druk je op de pijltjes links van de OK-knop. In dezelfde volgorde komen de waarden ook in je menu. Bij Item Label geef je het label in van de waarde, hoe die waarde wilt zien in je lijst, bij Value geef je de waarde zelf in, zoals je ze wil verwerken. In dit geval zijn dat cijfers, maar dat kunnen evengoe letters zijn of dezelfde namen die je gekozen hebt bij Item Label. 

· Initially Selected (in de property inspector): Hier duidt je de waarde aan die je standaard wil geselecteerd zien. 

De eigenschappen van een lijst

De eigenschappen van een lijst komen grotendeels overeen met die van een menu.
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Als type kies je hier voor lijst. Je zal zijn dat de attrubuten Height en Selections nu ook beschikbaar zijn. Height betekent de hoogte, het aantal lijnen van je lijst. Als je selections, Allow multiple aanvinkt wil dat zeggen dat je meer dan 1 waarde zal kunnen selecteren uit je lijst.

De eigenschappen van een Jump Menu

Een jump-menu kan je ook buiten een formulier gebruiken. Jump-menu's worden vaak gebruikt in websites als vereenvoudigd menu, om snel naar andere pagina's te gaan. Je kan het een beetje vergelijken met een gewoon menu, maar in plaats van een waarde op te geven moet je een URL opgeven. Als je dan een item in het jump-menu aanklikt, ga je naar de desbetreffende URL. 

Als je een Jump-menu invoegt, zal Dreamweaver automatisch een JavaScript toevoegen aan je html-code, maar hiervan moet je je niets aantrekken.
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Menu Items: dit zijn de verschillende Items (waarden) die je ingegeven hebt, je kan hier de volgorde wijzigen. Om een nieuw Item toe te voegen druk je op de "+", om een Item te verwijderen, selecteer je het Item, en druk je op de "-".
De tekst die je ingeeft bij Text, is wat er zal verschijnen in het menu. De URL die je daaronder kan ingeven, is de URL van de pagina die dan zal geopend worden als je in het menu klikt.

Om nadien nog waarden te gaan wijzigen ge je op dezelfde manier te werk als voor een gewoon menu. Je zal ook in hetzelfde venster terechtkomen.

Publiceren

Eens de website af is wil je die natuurlijk op het net zetten! Dit kan je in Dreamweaver zelf ook, maar zelf werken wij altijd met Globalscape CuteFTP. Dat is een heel makkelijk programma, dat je kan downloaden van de website van Globalscape. Meer informatie hierover, en nog veel andere nuttige zaken (vb een lijst met internetsites die gratis webspace aanbieden), zal je hier binnenkort kunnen vinden. 

